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Opening Solid Model File

Download the accompanying STEP file - Gear Housing.STEP to a location of your choice.

Menu: File -> Open

Toolbar button: 

Shortcut: Ctrl + O

Choose the File type to open - STEP Files, as shown below:

Navigate to the downloaded file, then select the Gear Housing.STEP file and click the Open
button.

SharpCam will read the units from the STEP file and set the units for the opened file as
required.

Units
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The units stored in any STEP file may not be correct and are arbitrary. It is always best to
check the unit settings for the opened file:

Choose the Options... command from the Tools menu:

Select the Active Part Settings node and make sure that the correct units are selected and
click the OK button:

A confirmation message box will be shown if the units are changed, click OK to accept.

Opening
other
types
of
CAD
files

Dxf/dwg/STL file units cannot be read, the opened file will adopt the units set for a new
Part, see below. Be sure to change the units if required, see above.

Choose the Options... command from the Tools menu:
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Select the New Part Defaults node. The Part Units group indicates the units that other CAD
files will adopt by default:

Other
Settings

For this tutorial it is assumed that the following buttons are depressed - as indicated by the
orange appearance:
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Create the Contours

Step 1 - Extract Contours from Model

Rather than drawing the Contours, we will extract them from the Solid Model

Extract
Contours
using
Extract
Contours
from
Face

Set the model view to isometric:
Menu: View -> Standard View -> Isometric View
Toolbar button: 

Extract Contours from top face:
Menu: View -> Solids -> Extract Contours from Face
Toolbar button: 
Highlight top face:
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Left click mouse to extract Contours from the top face:
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Extract Contours from counter bore face - highlight face:
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Left click mouse to extract Contours from the counter bore face:
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The Contours have now been extracted.

Step 2 - Set Contour Heights

Set
Contour
Heights
for
machining
depths

Deselect all Contours - Press the Escape Key:
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Highlight outer Contour on top face, left click to select, repeat for four circles on top face also:
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Set the Contour Heights:
Menu: Modify -> Set Contour Height
Toolbar button: 
The default value for the Top of the selected Contours is zero, this is correct, we want Z0 on the top of the
part. Click OK to accept:

We could fill in the Bottom value, but it is easier to pick the value from the model. Highlight a point on the
bottom edge:

Left click to enter value:
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The Contour heights will be set at the same time:

Press the escape key to deselect the Contours and exit the Set Contour Height command.
Highlight and select the inner pocket Contour:
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Choose the Set the Contour Heights command.
Click OK to accept the default Top value:

Pick the Bottom value from the model. Highlight a point on the bottom edge of the pocket:
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Left click to enter value:

The Contour heights will be set at the same time:
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The bottom of the Contour is hidden by the radius in the corner, you can set the view to Wire Frame to see
the bottom of the Contour:
Menu: View -> Wire Frame View
Toolbar button: 

Put the view back to Shaded View
Menu: View -> Shaded View
Toolbar button: 

Next delete the unwanted Contour in the bore.
Press the escape key to deselect the Contours.
Highlight and select the unwanted Contour:
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Choose the Delete command to remove unwanted Contour:
Menu: Edit -> Delete
Toolbar button: 
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Highlight bore Contour on top face, left click to select:
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Choose the Set the Contour Heights command
Click OK to accept the default Top value:

Pick the Bottom value from the model. Highlight a point on the bottom edge of the bore:
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Left click to enter value:

The Contour heights will be set at the same time:
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Press the escape key to deselect the bore Contour.
Highlight and select the slots and holes in the bore:
One of the slots is obscured, choose the Top View command to assist in selection.
Menu: View -> Top View
Toolbar button: 
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Switch back to Isometric View
Menu: View -> Standard View -> Isometric View
Toolbar button: 

Choose the Set the Contour Heights command.
Click OK to accept the default Top value:
Menu: Modify -> Set Contour Height
Toolbar button: 

Pick the Bottom value from the model. Highlight a point on the bottom edge of the outside:
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Left click to enter value:

The Contour heights will be set at the same time:
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Create the Toolpaths

Step 1 - Process plan

The Gear Housing is to be made from an aluminium rectangular billet 11.7" x 8.75" x 1.2".
The billet is to be held in a machine vice, leaving 1.08" protruding above the top of the
jaws. The Gear Housing is machined completely, leaving an operation to remove the excess
material that it was held with. This operation will not be covered during the tutorial.
For the purpose of this tutorial assume that the top of the billet is at Z0 and does not
require facing.

Before starting, a process plan is required:

Operation
Description

Operation
Type

Tool Comments

Rough outside profile Pocket T01, 0.75inch End Mill 0.02 finish
allowance

Rough Ø4.7 counterbore Pocket T01, 0.75inch End Mill 0.02 finish
allowance

Rough Ø2.0 and Ø2.75
bores

Pocket T01, 0.75inch End Mill 0.02 finish
allowance

Rough inside pocket Pocket T02, 0.5inch End Mill 0.02 finish
allowance

Finish outside profile Profile T03, 0.75inch End Mill  

Finish Ø2.0 and Ø2.75
bores

Profile T03, 0.75inch End Mill  

Finish Ø4.7 counterbore Pocket T03, 0.75inch End Mill  

Finish inside pocket Pocket T04, 0.5inch End Mill (0.08 Corner
Rad)

 

Machine radial slots Profile T05, 0.3125inch Slot Drill  

Spot Drill holes Drilling T06, 0.5inch Spot Drill  

Drill Ø0.3125 holes Drilling T07, 0.3125inch Drill  

Drill Ø0.375 holes Drilling T08, 0.375inch Drill  

Step 2 - Set start point

Set
start
point
on
closed
Contours
using
Set
Start
Point

Before creating any operations, it is recommended that the start point on closed contours
be set first.

Choose the Top View command.
Menu: View -> Top View
Toolbar button: 

Set the start point:

Menu: Modify -> Set Start Point
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Toolbar button: 

Choose the command and move the cursor near to the end of the line on the left:

Left mouse click to set the start point:
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Also set the start point on the upper left slot:
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Step 3 - Prepare for roughing

Prepare
for
Roughing
Outside
Profile

In order to rough the outside using a pocketing operation, a rectangle needs to be created
that will contain the toolpaths.

Choose the Rectangle command:

Menu: Draw -> Rectangle

Toolbar button: 

Create a rectangle with a start point value of X-3.35, Y-4.15 and an end point value of
X9.475, Y5.8:
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 The Part should now look like this:

By default the Contour that forms the rectangle has a Z Top and Z bottom of zero. The
outside profile and the rectangle will be used for the pocketing operation, they both must
have the same Z Top and Z bottom.

Press the escape key to exit Rectangle mode.
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Set the model view to isometric:
Menu: View -> Standard View -> Isometric View
Toolbar button: 

Highlight and left click the rectangle to select:

Set the Contour Heights:
Menu: Modify -> Set Contour Height
Toolbar button: 
The default value for the Top of the selected rectangle is zero, this is correct. Click OK to
accept:

Enter the value Z-1 in the Z Bottom and click OK
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The contour height has been set:

Step 4 - Rough outside profile

Rough
Outside
Profile
using
Pocket

Before choosing the pocket command, first select the cutting tool to be used for the
operation. The Tool Manager is used to select a tool:

Menu: Machine-> Tool Manger

Toolbar button: 

Before selecting a tool, first check that the Tool Manager is pointing to the correct folder.
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The folder is indicated by the Location of Tools box:

 

As this is an imperial Part the Inch tools folder, that was installed at the same time as
SharpCam, should be used. This folder is located in Documents (Vista)/Documents Library
(Windows 7, 8, 8.1), inside a folder called SharpCam Tools. If the location is wrong, click
the browse button  and navigate to 'SharpCam Tools' folder and select the Inch folder
and click OK:

Choose the command to display the Tool Manager, click on 'T01, 0.75inch End Mill', then
click the 'Select Tool' button. Alternatively double click a tool to select it.
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All the tools required for this tutorial were installed when SharpCam was installed for the first time.

 

The tool currently selected is displayed in the Status Bar at the bottom:

The outside is now ready to pocket, choose the command:

Menu: Machine-> Pocket

Toolbar button: 

Enter the following values for the Z Positions:
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The Finish Depth is taken from the Bottom of the contour, which is -1, so the actual depth is -1.04

The Depth of cut will not be correct until the contours have been added to the operation.

Enter the following values for the Cutting Data:

Choose the Top View command.
Menu: View -> Top View
Toolbar button: 

Select the outside profile and the outer rectangle by directly clicking them, the outer
rectangle may already be selected:
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To pocket the selected Contours click the Add button . The toolpaths are created:
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Looking at the resulting toolpaths a blue line can be seen in the top left hand corner. Blue
indicates an Entry, the entry is configured using the Entry tab:

By default Smart Ramp is checked and the blue line is a result of this. To see what Smart
Ramp is doing view the Part in an isometric view:

Menu: View -> Standard Views -> Isometric View

Toolbar button: 

Choose the command and zoom in on the Smart Ramp by pointing the cursor at the Smart
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Ramp and rotating the middle mouse button:

As can be seen the Smart Ramp, as the name implies, automatically ramps to depth at the
shallowest angle possible. As it is the outside profile that is being machined Smart Ramp is
not needed, because it is possible to plunge to depth outside of the billet.
First start from the outside, click the Advanced tab:

At the moment the pocketing starts from the inside, click the outside radio button and the
toolpaths will be recalculated to start from the outside:
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Choose the Entry tab and uncheck the Smart Ramp check box and check the Line check box:

Now the tool is plunging in fresh air:

To start further outside of the billet increase the length of the entry line. Change the entry
line length, for example, to 2 (2 x the tool radius = 0.75):
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To update this change click the Refresh button :

Changes to any value in a box are updated by clicking the Refresh button.

Step 5 - Rough counterbore

Rough
Ø4.7
counterbore
using
Pocket

Menu: Machine-> Pocket

Toolbar button: 

Choose the command and enter the following Z Positions:
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Enter the following values for the Cutting Data:

Choose the Top View command.
Menu: View -> Top View
Toolbar button: 

Select the Ø4.7 circle by directly clicking it:
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To pocket the selected Contours click the Add button . The toolpath is created:

This time Smart Ramp is required, this is still unchecked from the previous pocketing
operation. Choose the Entry tab and check Smart Ramp:

At the moment the pocketing starts from the outside, but it is preferable to start from the
inside. Choose the Advanced tab and select the Inside Radio button:
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The toolpath should look like this in isometric view:

Step 6 - Rough bores

Rough
Ø2.0
and
Ø2.75
bores
using
Pocket

Menu: Machine-> Pocket

Toolbar button: 

Choose the command and enter the following Z Positions:
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Enter the following values for the Cutting Data:

Select the Ø2.0 and Ø2.75 circles by directly clicking them:
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To pocket the selected Contours click the Add button . The toolpath is created:
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Step 7 - Rough inside

Rough
inside
pocket
using
Pocket

Menu: Machine-> Pocket

Toolbar button: 

Choose the command and THEN select the tool for this operation.

If a tool is selected, before choosing the Pocket command, SharpCam will assume that the current
operation  is to be created with a different tool and will regenerate the toolpath accordingly (do not forget
that the Ø2.0 and Ø2.75 bores have just been roughed and are still editing the operation).

Choose the Tool Manager:

Menu: Machine-> Tool Manger

Toolbar button: 

Choose the command to display the Tool Manager and click on 'T02, 0.5inch End Mill', then
click the 'Select Tool' button. Alternatively double click a tool to select it:
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Enter the following Z Positions:
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Enter the following values for the Cutting Data:

Select the Contour on the inside by directly clicking it:

 

To pocket the selected Contour click the Add button . The toolpath is created:
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Step 8 - Finish outside profile

Finish
outside
profile
using
Profile

Menu: Machine-> Profile

Toolbar button: 

Choose the Profile command then select the tool for this operation:

Menu: Machine-> Tool Manger

Toolbar button: 

Choose the command to display the Tool Manager and click on 'T03, 0.75inch End Mill', then
click the 'Select Tool' button. Alternatively double click a tool to select it:
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The Part now has a number of toolpaths. In order to prevent the view from being
obscured, suppress them so they are hidden. Choose the Operations tab on the Part Manager
and click the Suppress All button:
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All operations now indicate that they are suppressed and the toolpaths are now hidden:

Click the Properties tab on the Part Manager to continue with the Profile command:

Enter the following Z Positions:

Gear Housing 3D Tutorial  

49 Gear Housing 3D Tutorial



Enter the following values for the Cutting Data:

Select the outside Contour by directly clicking it:
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To profile the selected Contour click the Add button . The toolpath is created:
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Add an entry and exit. Choose the Entry tab and change the Line/Arc Angle to 0 and check
the Line check box:

 

Choose the Exit tab and check the Line and Arc check box:
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The entry and exit have been added:

Cutter radius compensation is required for this profile operation. Choose the Cutting Data
tab and select Control Tool Centre:
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When using Control Tool Centre, zero must be entered in the control offset table for
the correct size tool. Adjust the size with small + or - values.
If you prefer to enter the full radius in the control offset table, then choose Control.

Step 9 - Finish bores

Finish
Ø2.0
and
Ø2.75
bores
using
Profile

Menu: Machine-> Profile

Toolbar button: 

Choose the Profile command then select the tool and enter the following values for the Z
Positions:

Enter the following values for the Cutting Data:
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Select the Ø2.0 and Ø2.75 circles by directly clicking them:

To profile the selected Contours click the Add button . The toolpaths are created:
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As can be seen the toolpaths are on the outside and in a clockwise direction, this is the
default. This needs to be changed to the inside in a counter-clockwise direction.
The Contours must be selected in order to change the side and direction of the resulting
toolpaths. When Contours are added to an operation they will be left selected. If the
Contours are not selected they must be selected first, they can also be selected by clicking
the name in Contours group box:
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To change the side and direction click the appropriate radio button, in this case Inside and
CCW:

 The toolpath is now on the inside and in a counter-clockwise direction:
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Change the entry and exit because the settings from the previous operation are still in
effect. Choose the Entry tab and set the values (before checking the boxes) as below and
check the line and arc check box:

Choose the Exit tab and change the Length and Radius values and click the Refresh 
 button:
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The entry and exit have been added:

Cutter radius compensation is required for this profile operation. Choose the Cutting Data
tab and select Control Tool Centre, if not already selected:
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Deselect the Contours in readiness for the next operation:

Menu: Edit -> Deselect All

Toolbar button: 

Step 10 - Finish counterbore

Finish
Ø4.7
counterbore
using
Pocket

Menu: Machine-> Pocket

Toolbar button: 

Choose the command and enter the following values for the Z Positions:

Enter the following values for the Cutting Data:
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First deselect the bores from the previous operation, if required, by directly clicking them,
then select the counterbore Contour by directly clicking it:

To profile the selected Contour click the Add button . The toolpath is created:
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Smart Ramp is applied, but is not particularly suitable as the cutter will plunge against the
side wall. Choose the Entry tab, uncheck the Smart Ramp and change the line length to 1.
Check the Line (if not already selected) and then the Ramp check box:

This will create a smaller ramp from the centre of the counterbore:
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Step 11 - Finish inside

Finish
inside
pocket
using
Pocket

Menu: Machine-> Pocket

Toolbar button: 

Choose the command and then select the tool for this operation:

Menu: Machine-> Tool Manger

Toolbar button: 

Choose the command to display the Tool Manager and click on 'T04, 0.5inch End Mill (0.08
Corner Rad)', then click the 'Select Tool' button. Alternatively double click a tool to select
it:
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Enter the following values for the Z Positions:
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Enter the following values for the Cutting Data.
Note that the step over value has been changed from the default value of 0.25 to 0.17 to
ensure that pocket fully cleans up on the bottom, don't forget that the cutter has a 0.08
corner radius:

First deselect the counterbore from the previous operation, if required, by directly
clicking it, then select the Contour on the inside by directly clicking it:

To pocket the selected Contour click the Add button . The toolpath is created:
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The entry settings from the previous operation are acceptable.

Step 12 - Machine radial slots

Machine
radial
slots
using
Profile

Menu: Machine-> Profile

Toolbar button: 

Choose the Profile command then select the tool for this operation:

Menu: Machine-> Tool Manger

Toolbar button: 

Choose the command to display the Tool Manager and click on 'T05, 0.3125inch Slot Drill',
then click the 'Select Tool' button. Alternatively double click a tool to select it:
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Before machining the slots suppress the operation that machined the Ø4.7 counterbore, so
it does not obscure the view.
Choose the Operations tab on the Part Manager and right click on the last operation created
by 'T03, 0.75inch End Mill' and select Suppress:
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Click the Properties tab on the Part Manager to continue with the Profile command:

Enter the following values for the Z Positions:
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Enter the following values for the Cutting Data:

Select the slots by directly clicking them. Also unselect the Ø4.7 circle by directly clicking
it, it was selected when it was suppressed:
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To profile the selected Contours click the Add button . The toolpaths are created on the
outside by default, so you will not be able to see them as they are obscured by the model.

With the Contours still selected change the side to Inside and the direction to CCW:
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The toolpath is now on the inside and in counter-clockwise direction:

 

Gear Housing 3D Tutorial  

71 Gear Housing 3D Tutorial



Choose the Entry tab and set as below, changes the values before checking/unchecking the
boxes:

Choose the Exit tab and set the same as the entry:

The entry and exits have been added to all 4 slots:

 Gear Housing 3D Tutorial

72 Gear Housing 3D Tutorial



Step 13 - Spot drill holes

Spot
Drill
holes
using
Drilling

Deselect radial slots by pressing the Escape key twice.

Menu: Machine-> Drilling

Toolbar button: 

Choose the Drilling command then select the tool for this operation:

Menu: Machine-> Tool Manger

Toolbar button: 

Choose the command to display the Tool Manager and click on 'T06, 0.5inch Spot Drill', then
click the 'Select Tool' button. Alternatively double click a tool to select it:
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Enter the following Z Positions and Cutting Data as below, remember the Finish Depth is
from the bottom of the Contour which is -1:
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Select the Circles by directly clicking them:
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To drill the selected Circles click the Add button . The toolpaths are created:

As the Z position of the Ø0.375 holes are different a new drilling operation is required.

Menu: Machine-> Drilling

Toolbar button: 

Choose the Drilling command then enter the following values for the Z Positions:
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Select the Circles by directly clicking them:
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To drill the selected Circles click the Add button . The toolpaths are created:

Step 14 - Drill holes

Drill
Ø0.3125
holes
using
Drilling

Menu: Machine-> Drilling

Toolbar button: 

Choose the Drilling command then select the tool for this operation:

Menu: Machine-> Tool Manger

Toolbar button: 

Choose the command to display the Tool Manager and click on 'T07, 0.3125inch Drill', then
click the 'Select Tool' button. Alternatively double click a tool to select it:
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The Part now has a number of toolpaths. In order to prevent the view from being
obscured, suppress them so they are hidden. Choose the Operations tab on the Part Manager
and click the Suppress All button:

Gear Housing 3D Tutorial  

79 Gear Housing 3D Tutorial



Click the Properties tab on the Part Manager to continue with the Drilling command:

Enter the following Z Positions and Cutting Data as below, note that the type is Peck Drill:
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Select the Circles by directly clicking them:
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To drill the selected Circles click the Add button . The toolpaths are created:

 Gear Housing 3D Tutorial

82 Gear Housing 3D Tutorial



Step 15 - Drill holes

Drill
Ø0.375
holes
using
Drilling

Menu: Machine-> Drilling

Toolbar button: 

Choose the Drilling command then select the tool for this operation:

Menu: Machine-> Tool Manger

Toolbar button: 

Choose the command to display the Tool Manager and click on 'T08, 0.375inch Drill', then
click the 'Select Tool' button. Alternatively double click a tool to select it:
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Enter the following Z Positions and Cutting Data as below, note that the type is Drilling:
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Select the Circles by directly clicking them:
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To drill the selected Circles click the Add button . The toolpaths are created:
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 All toolpaths have now been created.

Step 16 - Create Material Stock

Create
Material
Stock
for
Solid
Simulation

First a rectangle must be created that represents the Material Stock. As mentioned in Step 1
the Gear Housing is to be made from an aluminium rectangular billet 11.7" x 8.75" x 1.2".

Choose the Rectangle command:

Menu: Draw -> Rectangle

Toolbar button: 

Create a rectangle with a start point value of X-2.7875, Y-3.55 and an end point value of
X8.9125, Y5.2:
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Set the model view to isometric:
Menu: View -> Standard View -> Isometric View
Toolbar button: 

Press the Escape Key to exit Rectangle mode.

Select the rectangle by directly clicking it:

 

Set the Contour Heights:
Menu: Modify -> Set Contour Height
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Toolbar button: 

 

Click OK to accept the default value of zero for the Z Top, then enter -1.08 in Z Bottom and
click OK:

Create the Material Stock by perform the Material From Contours command:

Menu: View -> Material Stock - >From Contours

Toolbar button: 

 

Step 17 - Solid Simulation
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Before simulating the part the operations must be unsuppressed. Choose the Operations tab
on the Part Manager and click the Unsuppress All button:

Simulate
part
being
machined

Menu: View-> Solid Simulation

Toolbar button: 

There are many options and you are encouraged to experiment, but for now you can press
either the Forwards button  or the Fast Forwards button . The part is simulated until
the end:
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Simulating the Part is optional and does not need to be performed to create the Nc code.

Step 18 - Output Nc code

Outputting
Nc
Code

Choose the Nc Code tab on the Part Manager :
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There are two choices:

Click the  button and save the Nc code to disk.

Click the  button and send directly to the machine, using RS232 communications.

 Gear Housing 3D Tutorial

92 Gear Housing 3D Tutorial



Gear Housing Drawing
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