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il Gear Housing Tutorial
Getting Started

Getting Started

Before starting this Gear Housing tutorial you should print the accompanying drawing from the
Learning Centre (http://www.sharpcam.co.uk/Training-Centre.aspx). Alternatively the
drawing is also located at end of this tutorial.

Open a New Part

Create a new Part, depending on your settings SharpCam may have created a new Part on
launch.

Menu: File -> New Part

Toolbar button: |
Shortcut: Ctrl + N

Units

Before starting it is important that the units are correct for the Part. When SharpCam was
installed the default units would have been set for a new Part. It is also possible to set the units
for an active Part. First check that the units are correct for the active Part:

Choose the Options... command from the Tools menu:

Tools

Snaps k
Tool Bars J
-] Properties

Machine Developer...
Configure Machine Definition...
R5232 Settings...

- Options... %

Select the Active Part Settings node and make sure that the Metric radio button is selected and
click the OK button:
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Opticns [E3m]
- General Arc Cirde Smoothness
- Appearance
- Colours Tools Folder Location:
[} New Part Defaults |C: Wsers\iia \Documents\SharpCam Tools\Metric | |:|
- General
- Appearance Machine Definition:
- Dimensions i
3 g . |C: Wserst e \Documents'SharpCam Machine Deﬁniﬁu:uns'n,Fanuc'n,Fanuc.mt| | |
=R Active Part Settings —
- General
- Dimensions
- Updates

|- oK || Cancel |

A confirmation message box will be shown if the units are changed, click OK to accept.

Other Settings

For this tutorial it is assumed that Connection Markers are displayed and Axis Icon at Origin is
not active:

B+ QERA[IvF]o® e-s o= -

Snap Orthogonal and Multi Snap are being used:
PEOAO Y X Ll [Z]= -
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Create the Contours
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Step 1 - Create three circles

Before starting decide the origin for the Part. In SharpCam the origin is not actually set, the
decision must be made where X0, YO is going to be located on the Part and create the Contours

around this point.
A logical place for X0, YO is the centre of the @120 circle.

Create three circles using Circle - Centre, Diameter

Menu: Draw -> Circle - Centre, Diameter

Toolbar button: ©

Choose the command and create a @120 circle, centred at X0, YO:

E’rﬂe ~ Eeni:re, ‘Diamefer

Diame

Centre

Create another circle @70 centred at X180, Y-45:
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Cirde - Centre, Diameter

Diameter

Ok,

Centre

),

e O

The Part should now look like this:
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Step 2 - Create offsets

Create a 5mm offset on the outside of the 3 circles using Offset
Menu: Modify -> Offset
Toolbar button: (7

Looking at the drawing it can be seen that there is a 5mm typical offset that applies to the
circles previously created.

Select the command and enter 5 into the Amount box. It does not matter if Contour or Element
is selected when offsetting from a circle:

o
|

120 Conbour

"I Element

Move the cursor over the @120 circle and left mouse click to indicate that the offset is to be
from this circle, then left click on the outside of the circle to create the offset; repeat for the
@50 and @70 circles:

O
O
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Step 3 - Create line

Create the left edge using Line
Menu: Draw -> Line

Toolbar button: /
Choose the command and move the cursor near to the 9 o'clock position on the @130 circle:

Snap the start point of the line to the quadrant point, the cursor is showing the Quadrant snap

symbol and a blue Snap Marker indicates the Snap Point. Left click the mouse to accept the Snap
Point and create the start of the line:

7 Gear Housing Tutorial



Gear Housing Tutorial [}

O
O Q

Move the cursor so it is below the start of the line, the cursor is showing the Vertical Orthogonal
snap symbol and a blue Snap Marker indicates the Snap Point. This will ensure that the line is
created vertically. Left click the mouse to accept the Snap Point and create the end of the line:

@
0 O
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Step 4 - Create line

Create the bottom edge using Line
Menu: Draw -> Line

Toolbar button: /
Choose the command and move the cursor near to the 6 o'clock position on the @80 circle:

K

Snap the start point of the line to the quadrant point, the cursor is showing the Quadrant snap
symbol and a blue Snap Marker indicates the Snap Point. Left click the mouse to accept the Snap
Point and create the start of the line:
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@
0 O

|
%.=.

Move the cursor so it is to the left of the start of the line, the cursor is showing the Horizontal
Orthogonal snap symbol and a blue Snap Marker indicates the Snap Point. This will ensure that
the line is created horizontally. Left click the mouse to accept the Snap Point and create the
end of the line:

@
0 O
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Step 5 - Create fillet

Create the R15 radius at the bottom lefthand corner using Fillet
Menu: Modify -> Fillet

Toolbar button: ¥

Choose the command and enter 15 in the radius box:

Filet

1

| Mo Radius

Highlight and left mouse click the two lines:

The fillet is created:
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Step 6 - Create line

Create the line tangentially between the @130 and @60 circles using Line
Menu: Draw -> Line
Toolbar button: /

Move the cursor near to the expected start point of the line but on the outside of the circle, the
cursor is showing the Tangent symbol. Left click the mouse to accept the Snap Point and create
the start of the line:

B

Move the cursor over the @60 circle to the expected position of the tangent point, keep moving
until the Tangent symbol is shown next to the cursor:

14 Gear Housing Tutorial



il Gear Housing Tutorial

9

Left mouse click to create the end point of the line tangentially between the two circles:

9
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Step 7 - Create line

Create the 60° line tangent to the @60 circle using Line
Menu: Draw -> Line
Toolbar button:

Move the cursor near to the expected start point of the line but on the outside of the circle, the
cursor is showing the Tangent symbol. Left click the mouse to accept the Snap Point and create
the start of the line:

Kﬂ'

o

To create the end point of the line specify an angle and length. Check the Angle/Length check
box and enter -120 into the Angle box and 70 in to the length box:
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Line

Start Point

X | 205,9307%

Y 115

End Point

I |
= |

X | 20598076
115

1l

¥ Angle/Length

!!

Click OK to create the end point of the line:

Line

Start Point

X | 205.98070

¥ 115

End Point

I O.
= |

X | 205.38076
115

O

=<

¥ Angle/Length

!!

The Part should now look like this:
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Step 8 - Create fillet

Create the R30 radius using Fillet

Menu: Modify -> Fillet

Toolbar button: ¥

Choose the command and enter 30 in the radius box:

il-éf”. 'r;_‘
| Mo Radius

Highlight and left mouse click the @80 circle and the 60° line:

9

The fillet is created:
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O
9
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Step 9 - Create offsets

Create 5mm offsets for internal pocket using Offset

Menu: Modify -> Offset

Toolbar button: (7

Choose the command and enter 5 into the Amount box, select the Element radio button:

ofset |

T

4

(7 Contour

i Element

Move the cursor over the line at the bottom edge and left mouse click to indicate that the offset
is to be from this line, then left click above the line to create the offset on the inside of the
gear housing. Repeat for the line at the top edge to create an offset on the inside as well:

/ __
\_/

Select the Contour radio button:

ofket |
o
4

(7 Contour

i~ Element
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Create an offset on the inside from the Contour formed by the 60° line:
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Step 10 - Create two circles

Create two circles using Circle - Centre, Radius
Menu: Draw -> Circle - Centre, Radius
Toolbar button: ©@

Choose the command and create a 15 radius circle, centred at X131, Y-70:

Create a second circle of the same radius but using snap to centre. Move the cursor over the
15mm radius, not near the end or mid point, until the Center snap symbol is showing and a blue
Snap Marker indicates the Snap Point. It may be necessary to zoom in on the 15mm radius by
pointing the cursor at it and rotating the middle mouse button:

o )
Nty 7

e

Traw

Left click the mouse to accept the Snap Point and create the circle:
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Step 11 - Create fillets

Create 8 off R6.5 Radii using Fillet
Menu: Modify -> Fillet
Toolbar button: ¥

Choose the command and enter 6.5 in the radius box:

[T Mo Radius

Fillet in 8 places, highlight and left mouse click the two elements that form the fillet:

s
e
~
-

[
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Step 12 - Trim contours

Trim unwanted sections of Contours using Trim
Menu: Modify -> Trim
Toolbar button: <

Choose the command and Trim in 10 places, highlight the section of unwanted contours and left

mouse click:
1.
¥
[
: .
3.
I \
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The Part should now look like this:

— U

(D 5
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Step 13 - Connect contours

Connect Contours using Connect
Menu: Modify -> Connect
Toolbar button: #°

When the Connect command is chosen, it connects all selected Contours. It does not matter if a
Contour is selected that does not need to be connected, as long as it cannot be connected.
Therefore use the Select All command to select the Contours:

Menu: Edit -> Select All
Toolbar button:
Shortcut: Ctrl + A

Now all the Contours are selected choose the Connect command, the part should now look like
this:

“\ S

All the Contours are now connected and are closed, as indicated by the orange connection
markers. There is still an open Contour in the bottom left hand corner, this is left over from the
trimming and needs to be deleted.

Select the Contour. It may not be possible to select the Contour by directly clicking it, the
outside Contour may be selected instead, in this case use a selection rectangle.

Right click over the Part to show the context menu and choose 'Select Mode '. Click away from
any Contours and drag the rectangle over the open contour:
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.

Now the Contour is selected use the Delete command to delete it:

Menu: Edit -> Delete
Toolbar button: ¥

The Part should now look like this:

o).

“\ J
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Step 14 - Create circle

Create a circle using Circle - Centre, Diameter
Menu: Draw -> Circle - Centre, Diameter
Toolbar button: ©@

Choose the command and create a @10 circle, centred at X50, YO:

Create another two circles of @90 and @110 centred at X0, YO, the Part should now look like
this:

A

//_

32 Gear Housing Tutorial



il Gear Housing Tutorial
Step 15 - Rotate circle

Rotate the @10 circle using Rotate
Menu: Modify -> Rotate

Toolbar button: of

First select the @10 circle, right click over the Part to show the context menu and choose 'Select
Mode’ and directly click the circle. Then choose the Rotate command and rotate around a centre
of X0, YO by 10°, once:

Rotate

Centre

X

[

Mumber (In total)

I

Cox

[#] Indude Toolpaths

Leaving the circle selected rotate again by 70°, but keeping the original circle by specifying 2
for the Number box:
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Centre

I

Mumber {In total)

() ()
= =
e

E

Indude Toolpaths

The Part should now look like this:

//_
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Step 16 - Trim contours
Trim unwanted section of Contours using Trim
Menu: Modify -> Trim
Toolbar button: <

Choose the command and Trim in 4 places, highlight the sections of unwanted contours and left
mouse click:

1. e
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.

The Part should now look like this:
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Step 17 - Connect contours

Connect slot using Connect
Menu: Modify -> Connect

Toolbar button: #°

First select the 4 arcs that make up the slot using a selection rectangle. Right click over the Part

to show the context menu and choose 'Select Mode'. Click away from any Contours and drag the
rectangle over the open contour:

k J

Choose the Connect command, the Part should now look like this:
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Step 18 - Rotate contour

Rotate the slot using Rotate
Menu: Modify -> Rotate

Toolbar button: of

First select the slot, right click over the Part to show the context menu and choose 'Select Mode'
and directly click the slot. Then choose the Rotate command and rotate around a centre of X0,
Y0 by 90°, in 4 places:

Rotate

EEﬂfrE

X

1

Mumber (In total)

1

K

F

Indude Toolpaths

The Part should now look like this:
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Step 19 - Create circles

Create circle using Bolt Hole Circle

Menu: Draw -> Bolt Hole Circle

Toolbar button: %

Choose the command and enter the following values:

Bolt Haole Cirde

Mumber of Holes

I

Hole Diameter

I

]

Pitch Cirde Diameter

a0

D

Centre Point

Il

-

First Hole Angle

D

Click the Apply button to action the command.

The Part should now look like this:
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Step 20 - Create circles

Create two circles using Circle - Centre, Diameter
Menu: Draw -> Circle - Centre, Diameter

Toolbar button: ©@
Choose the command and create two @8.5 circles, centred at X131, Y-70 and X-50, Y-70:

The creation of the Contours is now complete.
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Create the Toolpaths
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Step 1 - Process plan

The Gear Housing is to be made from an aluminium rectangular billet 295mm x 225mm x 30mm.
The billet is to be held in a machine vice, leaving 27mm protruding above the top of the jaws.
The Gear Housing is machined completley, leaving an operation to remove the excess material
that it was held with. This operation will not be covered during the tutorial.

For the purpose of this tutorial assume that the top of the billet is at ZO and does not require
facing.

Before starting, a process plan is required:

Operation Description |Operation Type Tool Comments
Rough outside profile Pocket TO1, 20mm End Mill 0.5 finish allowance]
Rough @120 counterbore [Pocket [TO1, 20mm End Mill 0.5 finish allowance]

Rough @50 and @70 bores|Pocket

[T01, 20mm End Mill

0.5 finish allowance|

Rough inside pocket

Pocket

T02, 12mm End Mill

0.5 finish allowance|

Finish outside profile

Profile

[T03, 20mm End Mill

Finish @50 and @70 bores

Profile

[T03, 20mm End Mill

Finish @120 counterbore |Pocket [T03, 20mm End Mill

Finish inside pocket Pocket [T04, 12mm End Mill (Zmm Corner Rad)
Machine radial slots Profile [T05, 8mm Slot Drill

Spot Drill holes Drilling [TO6, 12mm Spot Drill

Drill @8.5 holes Drilling [T07, 8.5mm Drill

Drill @10 holes Drilling [TO8, 10mm Drill

46
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Step 2 - Set start point

Set start point on closed Contours using Set Start Point

Before creating any operations, it is recommended that the start point on closed contours be set
first.

Menu: Modify -> Set Start Point
Toolbar button: [
Choose the command and move the cursor near to the end of the line on the left:

Left mouse click to set the start point:
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Step 3 - Prepare for roughing

Prepare for Roughing Outside Profile

In order to rough the outside using a pocketing operation, a rectangle needs to be created that
will contain the toolpaths.

Choose the Rectangle command:
Menu: Draw -> Rectangle

Toolbar button: &
Create a rectangle with a start point value of X-87, Y-107 and an end point value of X242, Y152:

The Part should now look like this:
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Step 4 - Rough outside profile

Rough Outside Profile using Pocket

Before choosing the pocket command, first select the cutting tool to be used for the operation.
The Tool Manager is used to select a tool:

Menu: Machine-> Tool Manger
Toolbar button: &

Before selecting a tool, first check that the Tool Manager is pointing to the correct folder. The
folder is indicated by the Location of Tools box:

Name | | |£|Type [Fiat Ml -
Number Diameter | 0|
Direction Offset | 1|
= Tool Length | 0|

. Rac |:| Flute Length | 0|
w o | |

= Close

Location of Tools:

|C WWsers\i&a" \DocumentsSharpCam Tools\Metric | |_|

) (B8] (] (o] (7] (] () (&) (T) (&) (W)

As this is a metric Part the Metric tools folder, that was installed at the same time as SharpCam,
should be used. This folder is located in My Documents (Windows XP)/Documents
(Vista)/Documents Library (Windows 7), inside a folder called SharpCam Tools. If the location is
wrong, click the browse button L.l and navigate to ‘SharpCam Tools' folder and select the
Metric folder and click OK:
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-

Browse For Folder @

Please select where your Tools folder is located for the
active Part

. SharpCarn Machine Definitions &
4 | SharpCam Tools
Inch
. Metric

m

4| 1 b

Im.ake Mew Folder l [ Ok H Cancel I

Choose the command to display the Tool Manager, click on TO1, 20mm End Mill', then click the
‘Select Tool' button. Alternatively double click a tool to select it.

£ All the tools required for this tutorial were installed when SharpCam was installed for the first time.
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The tool currently selected is displayed in the Status Bar at the bottom:

=

oo vereo N, =~ ==

Name [T01, 20mm End Mil @ Type [Flat Mil

Mumber Diameter |

Tool Length |

Flute Length |

Induded Angle |

ovecton [Codonse - offet|
Lreate 100

-l
Sawve Changes

|, Select Tool || |, Rename ||

Location of Tools:

|C:‘|,I_Jsers‘glul-" DocumentsYSharpCam Tools\Metric | F|
T (&) (7] (U] (¥ (E] (w] (F] (T](E][T]

T 102, 12mm End Mil

"IT 103, 20mm End Mil

7 104, 12mm End Mill (2mm Corner Rad)
"IT’ 705, 8mm Slot Dril

"B’ 106, 12mm Spot Dril

§' 107, 8. 5mm Dril

g’ 108, 10mm Dril

¥ T09, M10 Tap

Selected Tool T01, 20mm End Mill

The outside is now ready to pocket, choose the command:

Menu: Machine-> Pocket
Toolbar button: @
Enter the following values for the Z Positions:

53
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Initial Rapid

Material Surface

Finish Depth
Mumber of Passes
Depth of Cut

Enter the following values for the Cutting Data:

et |EEMIEEEA
Spindle Speed &000

Plunge Feed Rate
Cut Feed Rate
Finish Allowance
Stepover | 1]

Coolant |Flood -

Select the outside profile and the outer rectangle by directly clicking them:
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R

To pocket the selected Contours click the Add button ‘i’ The toolpaths are created:

55
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L

Looking at the resulting toolpaths a blue line can be seen in the top left hand corner. Blue
indicates an Entry, the entry is configured using the Entry tab:

e o IR

Smart Ramp ¥

By default Smart Ramp is checked and the blue line is a result of this. To see what Smart Ramp
is doing view the Part in an isometric view:

Menu: View -> Standard Views -> Isometric View
Toolbar button: &

Choose the command and zoom in on the Smart Ramp by pointing the cursor at the Smart Ramp
and rotating the middle mouse button:
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As can be seen the Smart Ramp, as the name implies, automatically ramps to depth at the
shallowest angle possible. As it is the outside profile that is being machined Smart Ramp is not
needed, because it is possible to plunge to depth outside of the billet.

First start from the outside, click the Advanced tab:

TR o= |
Start At

i Inside 71 Qutside

Cut Direction

20 Climb ™) Conventional

At the moment the pocketing starts from the inside, click the outside radio button and the
toolpaths will be recalculated to start from the outside:

EEEEREGA = |

() Inside Fi0utside

Cut Direction

(0 Climb 71 Conventional
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Choose the Entry tab and uncheck the Smart Ramp check box and check the Line check box:

s P

Line

Length: Tool Rad x | 1| [&]

Radius: Tool Rad x [

Line fArc Angle

Smart Ramp | [~ Ramp [7]

Now the tool is plunging in fresh air:

To start further outside of the billet increase the length of the entry line. Change the entry line
length, for example, to 2 (2 x the tool radius = 20):
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Cutting Data  |M=ilig] Advanced

Line

Length: Tool Rad x

n
l
<]

Ar

Radius: Tool Rad x
LinefArc Angle

Smart Ramp Ramp

To update this change click the Refresh button :

Changes to any value in a box are updated by clicking the Refresh button.
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Step 5 - Rough counterbore

Rough @120 counterbore using Pocket
Menu: Machine-> Pocket
Toolbar button: &

Choose the command and enter the following Z Positions:

Initial Rapid

Feed From
Material Surface
Finish Depth -14.5

Retract

Mumber of Passes

Depth of Cut

Enter the following values for the Cutting Data:

| cutngoats |EETMNEETSN

Spindle Speed 2000
Plunge Feed Rate 500
Cut Feed Rate 750

Finish Allowance 5

Step Over

[o=]
[y h

Coolant |Flood

Select the @120 circle by directly clicking it:
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To pocket the selected Contours click the Add button . The toolpath is created:
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| —

RN

\-\O

O
= )

This time Smart Ramp is required, this is still unchecked from the previous pocketing operation.

Choose the

Entry tab and check Smart Ramp:

Cutting Data [ Entry l

Smart Ramp

g

At the mom

ent the pocketing starts from the outside, but it is preferable to start from the

inside. Choose the Advanced tab and select the Inside Radio button:

62
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i
Start At

(TiInside (7 Qutside
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Step 6 - Rough bores

Rough @50 and @70 bores using Pocket
Menu: Machine-> Pocket
Toolbar button: &

Choose the command and enter the following Z Positions:

Initial Rapid
Feed Fram

Material Surface

Retract

Mumber of Passes

Depth of Cut

Enter the following values for the Cutting Data:

| cutsngoata VRN

Spindle Speed 8000

Plunge Feed Rate
Cut Feed Rate
Finish Allowance

Step Over

Ln
= [
= o

Coolant |Flood -

Select the @50 and @70 circles by directly clicking them:
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To pocket the selected Contours click the Add button . The toolpath is created:
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Step 7 - Rough inside

Rough inside pocket using Pocket

Menu: Machine-> Pocket

Toolbar button: @

Choose the command and THEN select the tool for this operation.

=If a tool is selected, before choosing the Pocket command, SharpCam will assume that the current operation is to
be created with a different tool and will regenerate the toolpath accordingly (do not forget that the @50 and
@70 bores have just been roughed and are still editing the operation).

Choose the Tool Manager:
Menu: Machine-> Tool Manger

Toolbar button: &

Choose the command to display the Tool Manager and click on 'T02, 12mm End Mill', then click
the 'Select Tool' button. Alternatively double click a tool to select it:

Teoimeneger N e
Name [T02, 12mm End Mil | @ Type [Flat Mil -
Number Diameter | 12| H
h Direction Offset | 2/l
Pi |:| Tool Length | 30|
ComerRad[ 0 Flute Length | 25|

Create Tool Save Changes I Delete I

|f Select Tool ]| |f Rename 1| |! Close 1|

Location of Tools:

|C:‘|.I_J5ers‘|, #=1'\Documents\SharpCam Tools\Metric | |ﬁ|

o] (&] (7] (©] (] (&) (w] (7] @] (] [(v)

"IT 101, 20mm End Mil
W T02, 12mm End Mil
[T 103, 20mm End Mil
T 104, 12mm End Mill (2mm Corner Rad)
*IT T05, 8mm Slot Cril
g’ 106, 12mm Spot Dril
"B’ 107, 8. 5mm Dril
"§' 108, 10mm Dril

g 109, M10 Tap
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Enter the following Z Positions:
Initial Rapid

Feed From

Material Surface
Finish Depth 1

Retract

Mumber of Passes

Depth of Cut

LLLLL

Enter the following values for the Cutting Data:

[ congooe |IEGRREEEA

Spindle Speed 10000

Flunge Feed Rate
Cut Feed Rate 2500

Finish Allowance

Step Over

Coolant |Flood -

Select the Contour on the inside by directly clicking it:
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To pocket the selected Contour click the Add button . The toolpath is created:
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Step 8 - Finish outside profile

Finish outside profile using Profile

Menu: Machine-> Profile

Toolbar button: J

Choose the Profile command then select the tool for this operation:
Menu: Machine-> Tool Manger

Toolbar button: &

Choose the command to display the Tool Manager and click on 'TO3, 20mm End Mill', then click
the 'Select Tool' button. Alternatively double click a tool to select it:

- - ] |

Name [T03, 20mm End Mil | @ Type [Flat Mil -

Number Diameter| 2D| E
e — ore| ||

Tool Length | EU|

Corner Rad |:| Flute Length | 35|

Create Tool Save Changes I Delets !

|f Select Tool ]| |r Renarme 1| |! Close 1|

Location of Tools:

|C:‘|,I.Jsers‘gl-l- Documents\SharpCam ToolsYMetric ||ﬁ
T (&) (7] (U] (¥ (E] (w] (F] (T](E][T]

"7 701, 20mm End Mil

"IT' 102, 12mm End Mil Filter - Reamer |
T T03, 20mm End Mill

7 104, 12mm End Mill (2mm Corner Rad)
"IT’ 705, 8mm Slot Dril

"B’ 106, 12mm Spot Dril

§' 107, 8. 5mm Dril

g’ 108, 10mm Dril

¥ T09, M10 Tap

The Part now has a number of toolpaths. In order to prevent the view from being
obscured, suppress them so they are hidden. Choose the Operations tab on the Part Manager and
click the Suppress All button:
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DA RE 9 X

Bl ¢

E__'Er T01, 20 End Mil

(@ Pockett

- # (@ Pocketz

: (0} Pockets

=TT 102, 12mm End Mil
#- (@ Pockets

[ ﬁ-ﬁ—ﬁu Operations l

»Q-Q-@Q-H-T- N

. Properties

Gear Housing Tutorial [}

All operations now indicate that they are suppressed and the toolpaths are now hidden:

'; Eile Edit “iew Draw Machine Modify Tools  Windo

NS

2E e

EEEE

E-"_E TO1, 20mm End Ml

§ @ Pockett

@ Pocketz

: [ Pocket3

=[5 T02, 12mm End Mil
@ Pocket4

[ ﬁﬁﬁu Operations l

ool zZN&

Click the Properties tab on the Part Manager to continue with the Profile command:

2 File Edit View Draw Mact

e 5o R 10
. aas.085

[ =[5 T4, 20mm End Mil

. @ @ Pocket1

. - @ Pocket2

. - @ Pocket3

= T3 02, 12mm End Mill
- @ Pocketd

DD T

ﬁﬁu Operations

E® Properties

(4]
I

Enter the following Z Positions:
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Initial Rapid
Feed From
Material Surface
Finish Depth

Retract

L

Mumber of Passes

Depth of Cut @] EI

Enter the following values for the Cutting Data:

[ crngoer RIS
Spindle Speed 3000

Flunge Feed Rate

Cut Feed Rate
Finish Allowance
Coolant |Flood

Cutter Radius Comp

il

Sub Routines

Select the outside Contour by directly clicking it:
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To profile the selected Contour click the Add button |i| The toolpath is created:
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Add an entry and exit. Choose the Entry tab and change the Line/Arc Angle to 0 and check the
Line check box:

[ Cuting Dat=_ ([ Exit |
Line

Length: Tool Rad x 1] &

Radius: Tool Rad x 1 [f
Ramp |l Angle 0

Arc

Choose the Exit tab and check the Line and Arc check box:
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CuttingData | Entry (M=Sll

Line

Length: Tool Rad x 1] ¥

Radius: Tool Rad x 1] ¥
Ramp [f Ferp || Angle a0

Arc

The entry and exit have been added:

e

Cutter radius compensation is required for this profile operation. Choose the Cutting Data tab
and select Control Tool Centre:
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l Cutting Data |mm
Spindle Speed
Flunge Feed Rate 500
Cut Feed Rate
Finish Allowance Ijl

Coolant  |Flood -
Cutter Radius Comp -
Sub Routines iakhnz
Control Tool Centre
Control h

Contours to Profile

When using Control Tool Centre, zero must be entered in the control offset table for the
correct size tool. Adjust the size with small + or - values.
If you prefer to enter the full radius in the control offset table, then choose Control.

77 Gear Housing Tutorial



Gear Housing Tutorial [}
Step 9 - Finish bores

Finish @50 and @70 bores using Profile
Menu: Machine-> Profile
Toolbar button: J

Choose the Profile command then select the tool and enter the following values for the Z
Positions:

Initial Rapid
Feed From
Material Surface
Finish Depth

Retract

L

Mumber of Passes

Depth of Cut . -

Enter the following values for the Cutting Data:

[Cutteapete SR
Spindle Speed

Flunge Feed Rate

Cut Feed Rate 1000
Finish Allowance

Coolant |Flood

A

Cutter Radius Comp |Mone

Sub Routines [T

Select the @50 and @70 circles by directly clicking them:
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O ) 3
e

To profile the selected Contours click the Add button @ The toolpaths are created:
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I'I.

As can be seen the toolpaths are on the outside and in a clockwise direction, this is the default.
This needs to be changed to the inside in a counter-clockwise direction.

The Contours must be selected in order to change the side and direction of the resulting
toolpaths. When Contours are added to an operation they will be left selected. If the Contours
are not selected they must be selected first, they can also be selected by clicking the name in
Contours to Profile group box:
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Contours to Profile

E] £
Closed(2) [[EETON

Selected Contours

 FiInside ) cow
7 Centre & cw
(5 Outside

External Corner Start

() Beginning of Arc (5 End of Arc

To change the side and direction click the appropriate radio button, in this case Inside and CCW:

E] X

Direction

External Corner Start [

() Beginning of Arc (5 End of Arc

The toolpath is now on the inside and in a counter-clockwise direction:
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Change the entry and exit because the settings from the previous operation are still in effect.
Choose the Entry tab and set the values (before checking the boxes) as below and check the line
and arc check box:

Line

Length: Tool Rad x o, 5| W

Arc

Radius: Tool Rad x W
Ramp [f Perp || Angle 90

Choose the Exit tab and change the Length and Radius values and click the Refresh button:
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| Cutting Data | Entry (SNl

Lime

Length: Tool Rad x 0.5 &

Arc

Radius: Tool Rad x i

Ramp [l Perp 7] Angle 90

The entry and exit have been added:

Cutter radius compensation is required for this profile operation. Choose the Cutting Data tab
and select Control Tool Centre:
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Cutting Data |mm
Spindle Speed
Flunge Feed Rate
Cut Feed Rate

Finish Allowance

Coolant |Flood

Cutter Radius Comp  |Control Tool Ce -

Sub Routines

il

Deselect the Contours in readiness for the next operation:
Menu: Edit -> Deselect All
Toolbar button:

84 Gear Housing Tutorial



il Gear Housing Tutorial
Step 10 - Finish counterbore

Finish @120 counterbore using Pocket

Menu: Machine-> Pocket

Toolbar button: @

Choose the command and enter the following values for the Z Positions:

Initial Rapid

Feed Fram -12.5
Material Surface -14.5
Finish Depth

Retract

- ] Ln rd

Mumber of Passes

Depth of Cut

Enter the following values for the Cutting Data:

[ oo |IEERIEEEER

Spindle Speed 2000

Plunge Feed Rate 1000
Cut Feed Rate

Finish Allowance

Lokl

Step Over 10

Coolant |Flood -

Select the Contour by directly clicking it:
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To profile the selected Contour click the Add button ‘i’ The toolpath is created:
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N

+
EETe O

\)

Smart Ramp is applied, but is not particularly suitable as the cutter will plunge against the side
wall. Choose the Entry tab, uncheck the Smart Ramp and change the line length to 1. Check the
Line and then the Ramp check box:

Cutting Data [ Entry ]

Line

Length: Tool Rad x

Radius: Tool Rad x

Line fArc Angle

Smart Rampf [~

This will create a smaller ramp from the centre of the counterbore:
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Step 11 - Finish inside

Finish inside pocket using Pocket

Menu: Machine-> Pocket

Toolbar button: @

Choose the command and then select the tool for this operation:
Menu: Machine-> Tool Manger

Toolbar button: &

Choose the command to display the Tool Manager and click on 'T04, 12mm End Mill (Zmm Corner
Rad)’, then click the 'Select Tool' button. Alternatively double click a tool to select it:

Eeme =

Mame |TCI4, 12mm End Mill {Zrmm I| @ Type |Bu|| Mose

Mumber Diameter |

Direction | Clockwise - Offset |

Pitch Tool Length |

Corner Rad Flute Length |

Miamater 3t T
Liameter at

Lreate 1o

;- Select Toal

Location of Tools:

|C:‘|,I.Jsers‘gl-l- Documents\SharpCam ToolsYMetric
T (&) (7] (U] (%] (E] (w] (F] (T](E][T]

"7 701, 20mm End Mil
"IT 102, 12mm End Mil
"7 103, 20mm End Mil
"IT 705, 8mm Slot Dril
"B’ 106, 12mm Spot Dril
§' 107, 8. 5mm Dril

g’ 108, 10mm Dril

¥ T09, M10 Tap

Enter the following values for the Z Positions:
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Initial Rapid 50

Feed From 1
Material Surface 19
Finish Depth
Retract

Mumber of Passes

Depth of Cut

Enter the following values for the Cutting Data.
Note that the step over value has been changed from the default value of 6 to 4 to ensure that
pocket fully cleans up on the bottom, don't forget that the cutter has a 2Zmm corner radius:

| cuttng vata | ETTINETER

Spindle Speed 10000

Plunge Feed Rate 1000
Cut Feed Rate
Finish Allowance

Step Qver

LA

Coolant |Flood

Select the Contour on the inside by directly clicking it:
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To pocket the selected Contour click the Add button ‘i’ The toolpath is created:
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The entry settings from the previous operation are acceptable.
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Step 12 - Machine radial slots

Machine radial slots using Profile

Menu: Machine-> Profile

Toolbar button: J

Choose the Profile command then select the tool for this operation:
Menu: Machine-> Tool Manger

Toolbar button: &

Choose the command to display the Tool Manager and click on 'T05, 8mm Slot Drill’, then click
the 'Select Tool' button. Alternatively double click a tool to select it:

- - ] |

Name |T05, 8mm Slot Dril | @ Type |Flat Mil -|
Mumber |:| Diameter| Ei| H
| oreston|cbconse ofset| 3l

Pitich |:| Tool LEﬂgth| 3U|
Corner Rad |:| Flute Length | 2[]|

Create Tool Save Changes I Delets !

|f Select Tool ]| |r Renarme 1| |! Close 1|

Location of Tools:

|C:‘|,I_Jsers‘g.}.g »'\DocumentsiSharpCam Tools{Metric | |. -

] (&] (7] ('] (7] (=) w] (7] (@] (][]

"7 701, 20mm End Mil

"IT 102, 12mm End Mil

"IT 103, 20mm End Mil

'UJ T04, 12mm End Mill (Zmm Corner Rad)
"B 106, 12mm Spot Dril
§' 107, 8. 5mm Dril

g’ 108, 10mm Dril

¥ T09, M10 Tap

Before machining the slots suppress the operation that machined the @120 counterbore, so it
does not obscure the view.

Choose the Operations tab on the Part Manager and right click on the last operation created by
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‘TO3, 20mm End Mill' and select Suppress:

IS File Edit View Draw Machine Modify T

DG RN o~ X -] EE]

P F— : -
bz BERL BBl
S (= —
/| & |2 T&T0L, 20mm End Mil
N 2 - @ Pocket1
= & [ Pocket2
O - @ Pocket3
O |[B | Z- TS 702, 12mm End Ml
B - (@ Pockets
o (=8 | = T 103, 20mm End Mil
0 B " fPruﬁIel
O G- ,:rF‘roﬁlez
o = '['704, 12omEr B2 Edit
il - (@ Pockets | Bg  Delete
K Rename
M= S f@ Suppress
Al : -
T 4~ | Zoom To
@ Use as Default
'_" %' Duplicate

i File Edit View Draw Machine Modify

D IR X - EE

i : -
Rl BEY o RE e
7 ‘:E; &[5 T01, 20mm End Ml
N = e @ Pocketi

= e @ Pocket2

| - @ Pocket3
o & = 'Em:'_, 12mm End Mil
o ‘E‘.L - @ Pockets

= = Ema, 20mm End Mill
9] B = o Profile1
O -- j Profile2
0 o G- @ Pockets

%! | =TT 104, 12mm End Mill (2mm Corner Rad)
& - @ Pocket?
< W

Enter the following values for the Z Positions:
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Tnitial Rapid

Feed From

Material Surface -15
Finish Depth

Retract

Mumber of Passes

Depth of Cut . -

Enter the following values for the Cutting Data:

Spindle Speed

Flunge Feed Rate
Cut Feed Rate
Finish Allawance
Coolant |Flood

Cutter Radius Comp  |Mone

Sub Routines

Select the slots by directly clicking them. Also unselect the @120 circle by directly clicking it, it
was selected when it was suppressed:
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To profile the selected Contours click the Add button . The toolpaths are created:
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With the Contours still selected change the side to Inside and the direction to CCW:

Contours to Profile

= -0 Il

Contours9
Contourg 1
Contourg2
Contourg3

(7 Inside
) Centre
) Outside

External Corner Start

(7 Beginning of Arc (5 End of Arc

The toolpath is now on the inside and in counter-clockwise direction:
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Choose the Entry tab and set as below, changes the values before checking/unchecking the
boxes:

P oratee IEGE o
Line
Length: Tool Rad x b
Radius: Tool Rad x EI F
Ramp | Angle

Arc

Choose the Exit tab and set the same as the entry:
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T |

Lime
Length: Tool Rad x (W

Arc

Radius: Tool Rad x F
Ramp || Angle

The entry and exits have been added to all 4 slots:
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Step 13 - Spot drill holes

Spot Drill holes using Drilling

Menu: Machine-> Drilling

Toolbar button: 2"

Choose the Drilling command then select the tool for this operation:
Menu: Machine-> Tool Manger

Toolbar button: &

Choose the command to display the Tool Manager and click on 'T06, 12mm Spot Drill’, then click
the 'Select Tool' button. Alternatively double click a tool to select it:

Eae =

Name [T08, 12mm SpotDril | @ Type [Dril

Mumber Diameter |

Direction | Clockwise - Offset |

Flute Length |

Tip Angle |

= Tl o gy,
Lreate 1o ogve LNanges

|, Select Tool 1| |f Rename |||

Location of Tools:

|C:‘|,I_Jsers‘alnl- Documents\SharpCam ToolsYMetric

] ([&] (7] ('] (7] [(B) W] (7] (@] (] (%]

"7 701, 20mm End Mil

"IT 102, 12mm End Mil

"IT 103, 20mm End Mil

7 104, 12mm End Mill (2mm Corner Rad)
"IT’ 705, 8mm Slot Dril

§' 107, 8. 5mm Dril
g’ 108, 10mm Dril
¥ T09, M10 Tap

Enter the following Z Positions and Cutting Data as below:
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Type |Dri||ing| - |

Initial Rapid
Feed From
Material Surface Ijl
Finish Depth

Retract To:

Cutting Data J

Spindle Speed 3000

Feed Rate
[ 9
[ 9]

Peck Amount
Dweell

Coolant |Flood -

Select the Circles by directly clicking them:

To drill the selected Circles click the Add button . The toolpaths are created:
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As the Z position of the @10 holes are different a new drilling operation is required.
Menu: Machine-> Drilling

Toolbar button: =

Choose the Drilling command then enter the following values for the Z Positions:
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Type |Dri||ing| - |
Initial Rapid
Feed From -13
Material Surface
Finish Depth

...........................

Retract To:

") Feed From
Cutting Data
Spindle Speed
Feed Rate
Peck Amount Ijl
Dwvell Ijl

Coolant |Flood -

Select the Circles by directly clicking them:
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To drill the selected Circles click the Add button . The toolpaths are created:
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Step 14 - Drill holes

Drill @8.5 holes using Drilling
Menu: Machine-> Drilling
Toolbar button: =%

Choose the Drilling command then select the tool for this operation:

Menu: Machine-> Tool Manger
Toolbar button: &

Choose the command to display the Tool Manager and click on 'T07, 8.5mm Drill’, then click the

‘Select Tool' button. Alternatively double click a tool to select it:

- - ] |

Name [T07, &. 5mm Dril | @ Type [Dril -

Number Diameter | 8.5

h Direction Offset | 7|
pch[ 0 Tool Length | 70

Corner :"\:—T|:| Flute Length | 50|
DiameteratTp[ 0 Tip Angle | 118|
Greate Tool save Changes Delete

| selectTool o | Rename Close

Location of Tools:

|C:‘|,IJsers‘|{- &= \Documents\SharpCam Tools\Metric

] (&] (7] ('] (7] (=) w] (7] (@] (][]

"7 701, 20mm End Mil

"IT 102, 12mm End Mil

"IT 103, 20mm End Mil

7 104, 12mm End Mill (2mm Corner Rad)
"IT’ 705, 8mm Slot Dril

"B’ 106, 12mm Spot Dril

g’ 108, 10mm Dril
¥ T09, M10 Tap

% T07, 8.5mm Oril

The Part now has a number of toolpaths. In order to prevent the view from being
obscured, suppress them so they are hidden. Choose the Operations tab on the Part Manager and

click the Suppress All button:
105
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%2 File Edit View Draw Machine Modify To

DS E RN 9 X[ BE
nl e i B ehe

[ = [ T01, 20mm End Mil
a- @ Pocket1

- @ Pocket2

- @ Pocket3

=- "J5 T02, 12mm End Mil
G- @ Pockets

=- "[5 T03, 20mm End Mill
-- :f Profilel

-- j Profile2

a- (@ Pockets

= T T04, 12mm End Mill (2mm Corner Rad)
- (@ Pocket7

= T T05, 8mm Slot Oril
- ‘:r Profie3

= g T06, 12mm Spot Dril

[ g% Drilling 1

- g¥g Drilling2

-3 - A -0 --Q-H-&N|&

ﬁﬁ-ﬁu Operations l

B Mo Code

Click the Properties tab on the Part Manager to continue with the Drilling command:

I5 File Edit View Draw Machine Modify T

IR

B ‘_I ..... |
{ e e -G
(=]
/| & |2 T&T01, 20mm End Mil
N & | = @Pocket
B e (@ Pocket2
[ - @ Pocket3
o1l | Ex I3 102, 12mm End Mil
E i @ Pocketd
[
O 2 ES 'Ema, 20mm End Mill
9] B -- 15 Profile1
O -- 5 Profile2
o G+ (B Pocket5
0] &8 | = T3 T04, 12mm End Mill (2mm Corner Rad)
& i @ Pocket7
< -l | - “[5 705, 8mm Slot Dril
E - 5 Profile3
&= | = 5 108, 12mm Spot il
A = Fél- ot Driling 1
i - ol Driling2

Enter the following Z Positions and Cutting Data as below, note that the type is Peck Drill:
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M

Type |Peck Dril

4

DSIT0NS
Initial Rapid
Feed From

Material Surface

L

Finish Depth -35
(7 Initial Rapid
Retract To: i
(= Feed From
& .LI.J C i'.'..
Spindle Speed 3000
Peck Amount

Coolant |Flood

4

Select the Circles by directly clicking them:

ﬁ
o O
O O Z
o O
e RE
N

*

To drill the selected Circles click the Add button . The toolpaths are created:
107 Gear Housing Tutorial



Gear Housing Tutorial [}

108 Gear Housing Tutorial



il Gear Housing Tutorial
Step 15 - Drill holes

Drill @10 holes using Drilling

Menu: Machine-> Drilling

Toolbar button: 2"

Choose the Drilling command then select the tool for this operation:
Menu: Machine-> Tool Manger

Toolbar button: &

Choose the command to display the Tool Manager and click on 'TO8, 10mm Drill', then click the
‘Select Tool' button. Alternatively double click a tool to select it:

E =

Name [T08, 10mm Dril | @Type [oril

Mumber Diameter |

Offset |

Tool Length |

Flute Length |

Tip Angle |

= Tl o gy,
Lreate 1o ogve LNanges

g=Selact Tookmg |f Rename |||

Location of Tools:

|C:‘|,I_Jsers‘alnl- Documents\SharpCam ToolsYMetric

] ([&] (7] ('] (7] [(B) W] (7] (@] (] (%]

"7 701, 20mm End Mil

"IT 102, 12mm End Mil

"IT 103, 20mm End Mil

7 104, 12mm End Mill (2mm Corner Rad)
"IT’ 705, 8mm Slot Dril

"B’ 106, 12mm Spot Dril

§' 107, 8. 5mm Dril

% T08, 10mm Dril

¥ T09, M10 Tap

Enter the following Z Positions and Cutting Data as below, note that the type is Drilling:
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4

Type |Dri||ing|

Inial Rapid

Feed From -13
Material Surface -15
Finish Depth -35
Siilnitial Rapid
Retract To: _
(") Feed From

O

Coolant |Flood

4

Select the Circles by directly clicking them:
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To drill the selected Circles click the Add button |i| The toolpaths are created:

All toolpaths have now been created.
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Step 16 - Create Material Stock

Create Material Stock for Solid Simulation

First a rectangle must be created that represents the Material Stock. As mentioned in Step 1 the
Gear Housing is to be made from an aluminium rectangular billet 295mm x 225mm x 30mm.

Choose the Rectangle command:
Menu: Draw -> Rectangle

Toolbar button: [
Create a rectangle with a start point value of X-70, Y-90 and an end point value of X225, Y135:

Rectangle

Start Corner Point

x[ ]

[ o]

End Corner Point
X | 225
Y| 135

- -

Extrude the rectangle
Menu: View-> Material Stock -> Extrude Contours

Toolbar button: & ->™
Select the Rectangle by directly clicking it:
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Enter -27 in Z Bottom:

Extrude Contour

Z Top

.......................

Click the Apply button, the Material Stock is created:
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Step 17 - Solid Simulation

Before simulating the part the operations must be unsuppressed. Choose the Operations tab on
the Part Manager and click the Unsuppress All button:

2 File Edit View Draw Machine Modify

O S R0 o X~ B E

= - "E'é‘@

=- "§& T01, 20mm End Mil
- (@ Pocket1

- (@ Pocket2

- @ Pocket3

=- I3 T02, 12mm End Mil
- [ Pocketd

=- "[5 T03, 20mm End Mill
-- 25 Profilel

-- 35 Profile2

- [ Pockets

=[5 T04, 12mm End Mill (2mm Corner Rad)
- [ Pockets

=- "% TO5, 8mm Slot Drill
- 35 Profile3

=- {5 T06, 12mm Spot Dril
(- gy Drilling1

& gy Drilling2

=- g T07, 8. 5mm Dril
- g% Drilling3

= B T08, 10mm Dril

G- gy Drilling4

| ﬁﬁ-ﬁu Operations |

RA| D>»EANO0O000O0Z\¥

Simulate part being machined
Menu: View-> Solid Simulation
Toolbar button: &

There are many options and you are encouraged to experiment, but for now you can press either
the Forwards button ¥ or the Fast Forwards button ». The part is simulated until the end:
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[ Simulating the Part is optional and does not need to be performed to create the Nc code.
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Step 18 - Output Nc code

Outputting Nc Code

Choose the Nc Code tab on the Part Manager :

=

- .
> File

Edit View Draw Machine Modify

DG IR 9 - X - E

|- mr»BEANDRQOOQOO TN

Gl

B® Properties

& |Fadal v| I |z

%
01 (EEAR HOUSING INCH)
(CYCLE TIME 0.73 MINUTES)
{TO7, 0_312Z5INCH DRILL)
{TOB, 0O_375IMCH DRILL)
=40 E17 &80
G531 GZEB Z0
MOl
T7 M& (T0O7, 0.2125INCH DRILL)
G0 =50 G54 ¥5.15 ¥-2_.75 M3 58000
=43 ZZ.0 H7T M5
83 G%B8 RO.1 Z-1.2 Q0.4 F25.0
—1_595
a0
31 =Z8 Z0 MO3
0l
g8 Mg (Tog, 0.375IMCH DRILL)
0 =50 G54 ¥1.175 ¥0.0 M3 57000
G43 Z0.1 HE MB
581 G%B R-0_5Z Z-1_2 F30._0
H0.5B875 ¥1.017&
¥-0.5875
X-1_175 ¥0._0
X-0_5B75 ¥-1_0176
X0.5875
GE0
=51 28 ZO0

There are two choices:

o Click the = button and save the Nc code to disk.

e Click the I button and send directly to the machine, using R$232 communications.
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Gear Housing Drawing
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Step 10 - Create two circles, 23-24
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Step 15 - Drill holes, 109-111
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Step 16 - Create Material Stock, 112-114
Step 16 - Trim contours, 35-37

Step 17 - Connect contours, 38-39
Step 17 - Solid Simulation, 115-116
Step 18 - Output Nc code, 117

Step 18 - Rotate contour, 40-41
Step 19 - Create circles, 42-43

Step 2 - Create offsets, 6

Step 2 - Set start point, 47-48

Step 20 - Create circles, 44

Step 3 - Create line, 7-8

Step 3 - Prepare for roughing, 49-50
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Step 7 - Rough inside, 67-70

Step 8 - Create fillet, 19-20

Step 8 - Finish outside profile, 71-77
Step 9 - Create offsets, 21-22

Step 9 - Finish bores, 78-84
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