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SharpCam System Requirements V1.6.0

SharpCam
up
to
and
including
Version
1.6

Hardware
Requirements

Minimum 512 megabytes of memory.
We have tested SharpCam on PCs fitted with an Intel Celeron 1.7GHz processor with
reasonable performance. SharpCam may well run on slower machines.
Please download and install the demonstration version before purchasing SharpCam.
This will ensure problems and disappointment are avoided.
A mouse with a middle button and wheel is recommended, but not essential.
A monitor that supports a minimum resolution of 1280 x 1024 is recommended, but
not essential.
SharpCam will only run on a single monitor system and will not run on dual monitor
systems.

Minimum
Operating
System
Requirements

Microsoft Windows XP with service pack 2 or higher.

Supported
Operating
Systems

Windows XP service pack 2 or higher
Windows Vista
Windows 7

Operating
systems
not
supported

Windows NT
Windows 95
Windows 98
Windows Me
Windows 2000

Server
versions

SharpCam has not and will not be tested on server versions of Windows, but will possibly run
on:

Windows Server 2003
Windows Server 2008

32
and
64
bit
systems

SharpCam will run on 32 and 64 bit systems.

Internet

An internet connection is recommended, but not essential. With an internet connection
SharpCam can be automatically updated to newer versions.
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Activation

An internet connection makes activation easier, but is not essential. If an internet
connection is not available on the PC on which SharpCam is to be installed then access to a
PC with e-mail is required. Also the facility to transfer files to and from the PCs is required.
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SharpCam 3D System Requirements V2.0.0

SharpCam
3D
-
greater
than
and
including
Version
2.0.0

Hardware
Requirements

Minimum 4GB of memory.
We have tested SharpCam 3D on PCs fitted with an Intel Core i3 processor with good
performance. SharpCam 3D may well run on slower machines.
Please download and install the demonstration version before purchasing SharpCam
3D. This will ensure problems and disappointment are avoided.
SharpCam 3D will run on 32bit processors, but will prove slow at times.
A mouse with a middle button and wheel is recommended, but not essential.
A monitor that supports a minimum resolution of 1280 x 1024 is recommended, but
not essential.
SharpCam 3D will only run on a single monitor system and will not run on dual
monitor systems.

Minimum
Operating
System
Requirements

Microsoft Windows Vista service pack 3 or higher.

Supported
Operating
Systems

Windows Vista service pack 3 or higher
Windows 7, 8, 8.1

Operating
systems
not
supported

Windows NT
Windows 95
Windows 98
Windows XP
Windows Me
Windows 2000

Server
versions

SharpCam 3D has not and will not be tested on server versions of Windows.

32
and
64
bit
systems

SharpCam 3D will run on 32 and 64 bit systems. 32bit processors, but will prove slow at
times, 64 bit recommended.

Internet

An internet connection is recommended, but not essential. With an internet connection
SharpCam 3D can be automatically updated to newer versions.

Activation
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An internet connection makes activation easier, but is not essential. If an internet
connection is not available on the PC on which SharpCam 3D is to be installed then access to
a PC with e-mail is required. Also the facility to transfer files to and from the PCs is
required.
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Installation

Accessing
the
software

When SharpCam is purchased you will receive an e-mail that includes a user name and
password. Use these to log in to the secure customer area on the SharpCam web site. From
the navigation buttons located at the top of every page, click 'Support', then 'Customer
Support' to display the login page.

Once logged in you can download the software. The software is available in two forms, a
Web deployment or an Offline deployment.

Web
deployment

This single file is designed for a PC that has an internet connection. Any prerequisite
software not installed will be downloaded as required.

Offline
deployment

This single file is designed for a PC that does not have an internet connection. All
prerequisite software is included, therefore is much larger in size.

Installation

Launch (Double click) the downloaded file and follow the instructions. Any previous versions
of SharpCam, including the demonstration one, will be uninstalled as part of the installation
process.

If the installation is the first ever the activation wizard is displayed. See Activation.

After activation the first time SharpCam is run the setup wizard is displayed. Click the Next
button to continue:
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Select the default units that a new Part will use. Click the Next button to continue:

Select if SharpCam should automatically check for updates when launched. Click the Next
button to continue:
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Setup is now complete. Click the Finish button and wait while SharpCam starts for the first
time:

When the setup wizard closes, a number of Machine Definitions are automatically installed
in a folder called SharpCam Machine Definitions. The location of this folder is in My
Documents (Windows XP)/Documents (Vista)/Documents Library (Windows 7).
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If a folder called SharpCam Machine Definitions already exists, then the folder is left untouched.

Also a set of Metric and Inch Tools are automatically installed in a folder called SharpCam
Tools. The location of this folder is in My Documents (Windows XP)/Documents
(Vista)/Documents Library (Windows 7).

If a folder called SharpCam Tools already exists, then the folder is left untouched.

Files
created
by
the
demonstration
version

Part files created by the demonstration version of SharpCam can be opened in the licensed
version, but the toolpaths are ignored and will not be loaded. As soon as the demonstration
file is saved in the licensed version the toolpaths are effectively removed.
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Activation

There are two way to activate SharpCam, automatic and manual. After SharpCam has been
installed for the first time the activation wizard is displayed.
If the licensing server cannot be reached while using the automatic activation method, then
please use the manual method. There can be a number of reasons why the licensing server
cannot be reached, typically related to firewalls.

Automatic

This is the most convenient method but requires an internet connection.

Select the Automatic activation radio button and click Next:

Log in to the My Account section on the SharpCam web site to retreive the activation code.
Enter the activation code, including all the hyphens, and click Next to activate. This could
take a few minutes.
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If activation is successful:

Click Finish to complete.

Manual
Activation

Use this method if the PC that you are performing the activation on does not have an
internet connection.
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Select the Manual activation radio button and click Next:

Select the Create a license file radio button and click Next:

Log in to the Secure Customer area on the SharpCam web site to retreive the activation
code.
Enter the activation code, including all the hyphens, and click Next to create the license
file:
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Choose a convenient location to save the license file to, for example the Desktop:

If the license file is created successfully:
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Click Finish to complete.

A file named SharpCam.lic (.lic may be hidden depending on the PC Settings) is saved to the
location specified.

Transfer the license file to a PC that has e-mail facility and send the file to
activation@sharpcam.co.uk as an attachment. This license file will be activated by
SharpCam and returned by e-mail. Transfer the license file back to the PC and repeat the
Manual Activation, but choosing the Load activated license file radio button:
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 Open activated license file that you received from SharpCam:

 If successful:

Getting Started  

15 Getting Started



Click Finish to complete activation.
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Training Resources

Tutorials and other training resources can be found at the Training Centre on the SharpCam
web site.

SharpCam also has a built in Help file, that acts as a complete reference and contains useful
information. You are encouraged to use this Help file, either by pressing F1 on your
keyboard or by clicking the  button, seen in various locations, as you work. The
appropriate page will be displayed for the action you are performing at that time.
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Machine Definitions

The Machine Definition controls all aspects relating to format and style of the NC code,
which is generated for the CNC control fitted to a machine tool. The Machine Definition is
akin to the term Post Processor as used by other CAD/CAM systems.

SharpCam comes pre installed with a set of Machine Definitions that are maintained by
SharpCam. Each Machine Definition has configurable properties specific to the
machine/control it is designed for. For example only one Fanuc Machine Definition is
supplied, that is configurable to suit most machines.

Contact SharpCam if any additional settings are required, this will help build up a powerfull
library of Machine Definitions.

The Machine Definition is configured with the Configure Machine Definition dialog box. The
Configure Machine Definition dialog box and Machine Definition are created and managed
with the Machine Developer. The Machine Developer is for advanced users and will not be
discussed in this document. Visit the Training Centre for more information on the Machine
Developer.

Configure
Machine
Definition
dialog
box

The Configure Machine Definition dialog box does not require any knowledge of the Machine
Developer and provides a simple interface to allow properties of the Machine Definition to
be changed.

Start SharpCam, then select Configure Machine Definition...

The Configure Machine Definition dialog box can be found under the Tools menu item:

The configuration shown is for the active Machine Definition associated with the active Part
at the time the Configure Machine Definition dialog box command was chosen.

User
Interface
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Properties
Pane

Lists all configurable properties for the Machine Definition. By default they are
categorized because the Categorized button above the Properties pane is pressed. The
adjacent button will list the properties alphabetically.

Property
Settings

The values of properties are changed by clicking in the appropriate box and either
entering a value or selecting from the list of options. If a new value is being entered
click out of the box or press the enter key on the keyboard to action the change.

Description
and
Display
Name

When a property is selected details are displayed in this pane. See below if not all of
the text can be seen.

Description
Splitter

If the text is too long for the description pane then use the splitter to increase the
size.

Vertical
Splitter
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Adjust to change the size of the Properties or Nc Code pane.

Nc
Code
Pane

Displays Nc Code for the current Part. The Nc Code is updated as soon as a property is
changed.

Help
Menu

Used to display the version of the Machine Definition.

 

The title bar text comprises of, on the left, the name and location of the Part with which
the Configure Machine Definition dialog box is associated. Any changes in the Properties
will affect this Part.
On the right is the name and location of the Machine Definition currently being configured.

Selecting
the
Machine
Definition
for
the
Active
Part

Select the Nc Code tab as shown below:

At the bottom of the Nc Code Tab the Active Machine Definition for the Part is displayed.
This is also where the Machine Definition is selected for the Part. Click the browse button
as indicated below and navigate to and select a Machine Definition for the Part.
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The default location for the Machine Definitions after installing SharpCam for the first time
is a folder called SharpCam Machine Definitions. The location of this folder is in My
Documents (Windows XP)/Documents (Vista)/Documents Library (Windows 7).
Inside the SharpCam Machine Definitions folder you will find the containing folders for the
Machine Definitions. Inside these folders is a file with an .mdf extension, this is the file that
should be selected when changing to a different Machine Definition.

The location of the Active Machine Definition is saved with the Part.

Setting
the
default
Machine
Definition
for
a
new
Part

It is also possible to set the default Machine Definition that is used for a new Part.

Choose the Options command located under the Tools menu:

Select the General node and click the browse button  to location the Machine Definition
that is to be used for a new Part:
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User Interface

The various aspects of the SharpCam interface are detailed below:

Menus
and
Toolbars

The menus and toolbars provide access to the SharpCam commands.

Client
Area

Displays all graphical objects. All drawing takes place here.

Part
Manager

The Part Manager is permanently docked to the left hand side of each Part.

Prompt

Displays prompts to give assistance in performing different commands.

Selected
Tool

Displays the currently selected tool that will be used for the next Operation.

Cursor
Position

Displays the X, Y and Z position of cursor in the Client Area.

Title
Bar

Displays the name of the application - SharpCam - and the name of the active Part. If
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the Part has been saved to disk then the full path is also included.

Multi
Document
Interface

SharpCam supports a multi document interface (MDI). This is a specification that defines a
user interface for applications, that enable the user to work with more than one document
at the same time. In the case of SharpCam, one or more Parts at the same time.

Each time a new Part is created any existing Parts are still kept open. There is no limit to
the number of Parts simultaneously open. Each Part is contained in a separate window and
can be in one of three states.
The state is controled by the three buttons in the top right hand corner of the Part window:

Maximized
State

When in the Maximized state the Part window will be merged into the Main window:

The button on the left will Minimize the Part window, the middle button Restore the Part
window and the right button close the Part.
When a Part window is maximized all other open Parts are also maximized, meaning you
cannot directly see or select other Part windows. Choose the Window menu command and
displayed at the bottom is a list of open Parts. The check indicates the active Part and by
selecting another listed Part it will become active.

Restore
State

When in the Restore state the Part window is separated from the Main window and is left
floating:

 

The button on the left will Minimize the Part window, the middle button Maximize the Part
window and the right button close the Part.

Minimize
State

When in the Minimized state the window is collapsed to bottom edge of the Main window:
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The button on the left will Restore the Part window, the middle button Maximize the Part
window and the right button close the Part.
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Concepts

When SharpCam is first started it will be in Select Mode as indicated by the depressed
toolbar button:

Select Mode is considered the default mode and cannot be cancelled.

There are three ways to return to Select Mode:

1. Click the Select Mode button on the Draw toolbar, as indicated in the above picture,
or from the Draw menu:

2. Right click in the client area to display the context menu and choose Select Mode:

 Getting Started

26 Getting Started



3. Press the escape key on the keyboard.

Entering
values

When a command is chosen that requires values or information to be entered, the user
interface is displayed in the Properties tab of the Part Manager. This ensures that the client
area is not obscured while entering values. For example, if the Line command is selected:
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The OK button acts to complete the command. When a command is completed it is not
cancelled but is still active, so it can be repeated.

If a different action is required it is not necessary to cancel the active command by
returning to Select Mode, choosing another command will effectively cancel the current
command.

If there is more than one stage to the command, e.g. when drawing a line, which needs a
start (stage 1) and end (stage 2) point, then there is an OK button for each stage.
The user interface has each stage grouped and only one will be active while the others are
disabled. Each stage has an OK button.

Taking the Line example again, the values for the start are entered first, then the OK
button is clicked:

The start point group of the line is now disabled and the end point group enabled. Fill in the
values and when the OK button is clicked the line is created:

 Getting Started

28 Getting Started



It is not possible to return to a previous stage, the command must be started again.

To repeat the previous command press the space bar on the keyboard.

Tips
on
entering
values

The tab key, as expected, will move the cursor to the next box. The enter key also moves
the cursor to the next box, this is especially useful when using the number pad on a full
keyboard. If data is being entered into the last box before the OK button, then pressing the
enter key effectively clicks the OK button. This method makes for rapid data entry.
The comma key also moves the cursor to the next box.

Boxes that take number values can also accept any combination of + - / * to perform
arithmetic calculations:

Press enter or tab to action the calculation.

Getting Started  

29 Getting Started



Creating Contours

Contours are a fundamental concept in SharpCam, they are defined as:

A
series
of
continuously
connected
lines
and/or
arcs.

A Contour can be comprised of a single line/arc, or thousands. Toolpaths are created
directly from Contours, there is no intermediate stage.

Contours can be connected, combining multiple Contours into one.

Connecting is central to the use of SharpCam. You may be familiar with other systems that
have a Chain or Chaining command that performs a similar task.

The process of connecting Contours ensures there is no ambiguity, for instance, where a
number of lines meet at the same point. This powerful concept allows the preparation
of the relationship of Elements to each other by grouping them together in a logical
manner, before you machine them. Because this is a pre machining operation, you can
machine unlimited number of Contours at once.

To Connect a series of Contours together simply Select the required Contours, then choose
the Connect command and all Contours, whose end points are the same, will be connected
together.

Contours are split up into two types: Open and Closed. With Connection Markers showing it
is easy to tell which type a contour is.

Open

Open contours will show an Open Contour Marker at the start and end points:

Closed

Closed Contours will show a Closed Contour Marker at the start point:

Accessing the Connect Command:

Menu: Modify -> Connect

Toolbar button: 
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To display Connection Markers, depress the Connection Markers button as indicated:

Circles are also considered a Contour, but cannot be connected in any way.

Connection Markers are especially useful for finding unwanted contours that may be lying under
existing contours, this is especially true for imported data.
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Selecting Contours

SharpCam works on the principle of selecting Contours and then performing an action.

There are a number of ways to select Contours.

Directly
selecting

Move the cursor over the Contour until it is highlighted (turns orange in colour) and the
cursor turns purple, then click the left mouse button:

The Contour is now selected as indicated by the blue colour:

To deselect a Contour, perform the above procedure on a selected Contour.

Selection
Rectangle

With this method it is possible to select multiple Contours at the same time.

Mouse the cursor away from any Contours so they are not highlighted, then left click and
release the mouse button:

As the cursor is moved a selection rectangle is drawn. Completley enclose the Contours that
are to be selected in the rectangle:
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Left mouse click to select the Contours:

Select
All

The Select All command, as the name implies, selects all Contours:

Menu: Edit -> Select All

Toolbar button: 

Shortcut: Ctrl + A

There is also a Deselect All command:

Menu: Edit -> Deselect All

Toolbar button: 
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Contour Heights

This
topic
only
applies
to
SharpCam
3D
-
Version
2.0
and
greater.

The top and bottom Z position of a Contour can be set use the Set Contour Height
command:

Menu: Modify -> Set Contour Height

Toolbar button: 

1. Select the Contours that require height setting, before choosing the Set Contour
Height.

2. Enter the Z position for the top of the selected Contours, alternatively the point can
be entered with the mouse, by snapping to a point on a Solid Model:

3. Enter the Z position for the bottom of the selected Contours, alternatively the point
can be entered with the mouse, by snapping to a point on a Solid Model:

4. Click on OK button to apply the heights:

Contour
Heights
and
Machining
Operations

The Z Top and Bottom influence the Z positions entered in Profile, Pocket, Drilling
and Thread Milling operations. Where Initial Rapid (when Abs* is unchecked), Feed
From, Material Surface and Retract (when Abs is unchecked), are taken from the Top of the
Contour. Finish Depth is taken from the Bottom of the Contour, enter a value of zero to
position at the bottom of the contour. If Initial Rapid or Retract has Abs checked, the
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position is the value entered.

* Absolute
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Changing the View

SharpCam has predefined views that can be selected at any time. These views are found on
the Standard View toolbar:

 

or on the View Menu:

Changing
the
view
with
the
mouse

The middle button/wheel on the mouse can be used to change the current view.

Zoom
In/Out

Point the cursor at the object that you wish to zoom in/out on and rotate the middle mouse
wheel to zoon in/out. The direction determines whether the view zooms in or out. The
direction can be swapped using the Options dialog box.
If the rotation of the wheel does not cause the zoom to change, press and release the
middle mouse button to make sure that the client area has the focus.

Panning

Press and hold down the middle mouse button, then move the mouse to pan the current
view. Release the mouse button when finished.

Rotate

Hold the Ctrl key down on the keyboard and press the middle mouse button down, then
move the mouse to rotate the current view. Release the mouse button when finished.

 Getting Started

36 Getting Started



Changing
the
view
with
commands

Zoom
All

Zooms all graphics to fit the Part Window.

All graphical objects that exist in the Part will be made to fit the window, so that all
objects are in view.

Accessing the command:

Menu: View -> Zoom All

Toolbar button: 

Zoom
Window

Zooms graphics to a rectangle.

Using the mouse, left click and release to specify the start corner of the rectangle. Move
the mouse diagonally, creating a rectangle around the graphical objects. Left mouse click to
finish, the rectangle will now be scaled to fit the current window size.

Accessing the command:

Menu: View -> Zoom Window

Toolbar button: 

Pan

Pans the view using the mouse. Left click and hold down the mouse button to indicate the
start of panning. Move mouse to pan view.
When the left mouse button is released to complete the Pan SharpCam remains in the Pan
command, so the view can be Panned again. The previous command is still active therefore
the Pan command should be cancelled to return. Press the escape key on the key board, or
right click in the client area, and choose Cancel Panning Mode:

Accessing the command:

Menu: View -> Pan
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Toolbar button: 

Rotate
View

Rotates the view around the centre of the all objects. Left click and hold down the mouse
button and move the mouse to rotate the view.

When the left mouse button is released to complete the Rotate SharpCam remains in the
Rotate command, so the view can be Rotated again. The previous command is still active
therefore the Rotate command should be cancelled to return. Press the escape key on the
key board, or right click in the client area, and choose Cancel Rotate View Mode:

Accessing the command:

Menu: View -> Rotate View

Toolbar button: 

Zoom
Out

Zooms out 5% each click around the centre of the current view.

Accessing the command:

Menu: View -> Zoom Out

Toolbar button: 

Zoom
In

Zooms in 5% each click around the centre of the current view.

Accessing the command:

Menu: View -> Zoom In

Toolbar button: 

Zoom
Previous

Zooms to previous view, undoing the last view change.

Accessing the command:
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Menu: View -> Zoom Previous

Toolbar button: 
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Glossary

C

Command
Whenever a Menu item, or Toolbar, button is pressed a Command is performed.

Contour
A series of continuously connected lines and/or arcs that are used to create
toolpaths.

F

Firewalls
A firewall is a part of a computer system or network that is designed to block
unauthorized access while permitting authorized communications

M

Machine
Definition
The Machine Definition controls all aspects relating to format and style of the NC
code, which is generated for the CNC control fitted to a machine tool. The
Machine Definition is akin to the term Post Processor as used by other CAD/CAM
systems.

O

Operation
Each time a Profile, Pocket or Drilling command is performed an Operation is
created.

P

Part
A term used to describe the part being machined. Each part is displayed in its
own window and when saved is stored in a file with a .mill extension.

T

Title
Bar
A Bar at the top of a window that typically contains a description of the window.
The window can be dragged around by this bar.

Toolpath
A generic term used to describe the path that a cutter will follow. A toolpath is
made up of a series of continuously connected lines and/or arcs. These are
shown in red in the Client Area.
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